개발 Q&A

제목 php mysql 버전이 다른경우 프로그램 관리
카테고리 기타
글쓴이 정수리 작성시각 2023/11/09 13:28:30
댓글 : 3 추천 : 0 스크랩 : 0 조회수 : 2521   RSS

동일한 프로그램을 운영하는 환경이

php7 mysql8 환경과php5 mysql5 환경이 있습니다.(사용하는 장소가 다른경우)

서로 버전차이가 좀 나다 보니프로그램을 운영하면 환경에 따라 코드를 수정해야 합니다.

그렇다보니 하나 수정이나 추가가 들어가면환경에 따라 2번의 작업을 해야하는 상황입니다.

프로그램 내에서 php와 mysql 버전에 따라 나눠서 코드를 작성하면 되는데

문제는 CI버전입니다.

한버전의CI이면 코드내에서 php, mysql버전만 따지면 되는데

php가 지원되는 CI버전이 2.x, 3.x 입니다.

ci3버전 개발한 프로그램을 ci2에 설치해서 해보니 여기저기 오류 발생해서 수정했던적이 있습니다.(메뉴얼도 참고해보니)

그렇다보니 ci버전도 php, mysql처럼 한코드 내에서 버전에 따라 수정하기에는 양이 많을 것 같습니다.

이런 상황에서는 어쩔수없이 ci2,ci3 따로 관리할 수 밖에 없을까요? 

 

 

 

 다음글 Interface "CodeIgniter\Ro... (5)
 이전글 ci4) 환경별, 다중DB를 구성하고싶은데 어떻게 진행... (2)

댓글

kaido / 2023/11/17 11:34:51 / 추천 1

최대한 손을 안대고 싶으면 저라면 따로 분리해서 운영 할것 같습니다.

환경에 따라서 프록시 서버로 구분만 짓고 말이죠.

그게 아니면 버전을 하나로 통합 하는게 일을 줄이는 방법일 수도 있습니다.  (php db ci 모두 통일을 의미)

버전을 체크해서 스위칭 하는 방법은 처음엔 스마트하다고 생각 될순 있지만, 막상 유지보수하다 보면 머리가 아픕니다. (개인적으로)

cilove / 2023/11/17 12:17:09 / 추천 1
저라면 환경을 맞출듯합니다.

큰 냉장고에 꽉차게 들어가는 물건을 작은 냉장고에 수셔넣으려면 물건을 빼야하듯이...
정수리 / 2023/12/04 09:36:43 / 추천 0

@kaido @cilove

답변감사합니다. 

달아주신 답변 참고해서 적절한 방법을 찾아보겠습니다